Updates to the latest DataPilot Mac Version
The following update requires Mac OS 10.3.9. Mac Logo

  • Download Mac 4.13.1 Updater


  • If you have Mac OS version 10.3.8 or lower, you can only upate your software to version 1.4.

  • Download Mac 1.4 Updater